Dovetail - User invites from settings page not working – Incident details

User invites from settings page not working

Resolved
Degraded performance
Started 7 months agoLasted about 1 hour

Affected

Website

Degraded performance from 6:15 PM to 7:22 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Apologies for the inconvenience!

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Identified
    Identified

    User invites from the Settings > User page currently do not work. As a workaround, invite users via the Project or Folder share flows.