Dovetail - Some emails may not be sending – Incident details

Some emails may not be sending

Resolved
Degraded performance
Started about 1 year agoLasted 14 minutes

Affected

AWS

Degraded performance from 11:07 PM to 11:20 PM

Emails

Degraded performance from 11:07 PM to 11:20 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.