Dovetail - Unable able to setup new Zapier integrations – Incident details
All systems operational
Unable able to setup new Zapier integrations
Resolved
Operational
Started over 2 years agoLasted about 3 hours
Updates
Resolved
Resolved
This incident has been resolved.
Monitoring
Monitoring
We have identified and fixed the issue, we will continue to monitor this
Investigating
Investigating
We are investigating reports of customers not being able to set up new Zapier integrations. This is not impacting customers that already have this setup.