Dovetail - Google Drive integration outage – Incident details

Google Drive integration outage

Resolved
Major outage
Started 3 months agoLasted 11 days

Affected

Integrations

Major outage from 8:26 PM to 12:32 AM

Google Drive

Major outage from 8:26 PM to 12:32 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved, and our Google Drive integration is now fully operational. Please reach out to our support team if you continue to experience issues.

  • Identified
    Update

    Update on ongoing Google Drive issue

    We have received a response from Google who have estimated the process may up to 7 days. We are in daily contact with them and will provide regular updates on it's progress until it is resolved.

    As a reminder, this outage impacts the ability to integrate Dovetail with Google Drive, preventing direct file uploads from Google Meet, Docs, Sheets, and all other files from Google Drive. However, files can still be manually downloaded from Google Drive and uploaded into Dovetail via Import → Browse → Upload files.

    We sincerely apologize for any inconvenience this is causing and if you need any support please don’t hesitate to reach out to our support team.

  • Identified
    Update

    This outage impacts the ability to integrate Dovetail with Google Drive, preventing direct file uploads from Google Meet, Docs, Sheets, and all other files from Google Drive. In the meantime, files can still be manually downloaded from Google Drive and uploaded into Dovetail.

    Update on the ongoing issue

    The outage occurred when our Google Drive integration became unverified due to a lapsed annual verification process. We've been working around the clock with Google's Trust & Safety team to rectify the issue.

    We have escalated the issue with Google and are actively working on the verification process. At this point, we don’t have an exact ETA on when this will be resolved, but we will provide daily updates.

    In the meantime, we have disabled the ability to connect with Google Drive. You are still able to import files to Dovetail by downloading them from Google Drive and manually uploading them to your Dovetail workspace via Import → Browse → Upload files.

    We apologize for any inconvenience caused by this outage and thank you for your ongoing patience while our team rectifies the issue.

    Our core services remain unaffected but if you need any support please don’t hesitate to reach out to our support team.

  • Identified
    Update

    We are continuing to communicate with Google to resolve this issue.

    Available workarounds

    Download files from Google Drive and manually upload to your Dovetail workspace via Import → Browse → Upload files.

  • Identified
    Identified

    Google team contacted for re-authorisation

  • Investigating
    Investigating
    We are currently investigating this incident.