Dovetail - Degraded Website Performance – EU Region – Incident details

Degraded Website Performance – EU Region

Resolved
Degraded performance
Started about 13 hours agoLasted about 1 hour

Affected

Dovetail web application

Major outage from 6:27 PM to 6:56 PM, Degraded performance from 6:56 PM to 7:28 PM

Projects

Major outage from 6:27 PM to 6:56 PM, Degraded performance from 6:56 PM to 7:28 PM

Channels

Major outage from 6:27 PM to 6:56 PM, Degraded performance from 6:56 PM to 7:28 PM

Recruit

Major outage from 6:27 PM to 6:56 PM, Degraded performance from 6:56 PM to 7:28 PM

Ask Dovetail

Major outage from 6:27 PM to 6:56 PM, Degraded performance from 6:56 PM to 7:28 PM

Magic features

Major outage from 6:27 PM to 6:56 PM, Degraded performance from 6:56 PM to 7:28 PM

Updates
  • Resolved
    Resolved

    The recent performance issues affecting the website in the EU region have been resolved.

    All services are now operating normally. Thank you for your patience while we addressed the issue.

  • Monitoring
    Monitoring

    Our team is actively monitoring the situation, and services are beginning to recover. You may still notice occasional slow page loads or timeouts as performance stabilizes.

    We will continue to provide updates until full normal performance is restored. Thank you for your patience.

  • Investigating
    Investigating

    Our website is currently slower than usual for users in the EU region due to high database load. Some pages may take longer to load or fail to respond occasionally.

    We’re working to resolve this issue and expect performance to improve soon.