Dovetail - Emails are temporarily unavailable – Incident details
All systems operational
Emails are temporarily unavailable
Resolved
Degraded performance
Started over 2 years agoLasted 14 minutes
Updates
Resolved
Resolved
This incident has been resolved.
Monitoring
Monitoring
A fix has been implemented and we are monitoring the results.
Identified
Identified
Any emails sent from Dovetail are temporarily unavailable. This affects all user invite emails, email verification and authentication, change password emails, share emails, and other email notifications sent from Dovetail.