Dovetail - Zapier integration: OAuth connection errors – Incident details

Zapier integration: OAuth connection errors

Resolved
Partial outage
Started 27 days agoLasted about 3 hours

Affected

Integrations

Partial outage from 4:00 PM to 6:38 PM

Updates
  • Resolved
    UTC
    Resolved

    We've rolled back the change that caused the Zapier OAuth connection errors. If you were affected, please try the following steps:

    1. Do a hard refresh of your browser (or log out of Zapier and log back in).

    2. Try connecting your Zapier integration again.

    This should now work as expected. If you're still running into issues after these steps, please email support@dovetail.com with a screen recording of the issue (with your browser console log open) so we can continue investigating.

  • Monitoring
    UTC
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    UTC
    Identified

    We've identified the root cause of the Zapier OAuth connection errors and are now working on a fix. We'll continue to post updates here as we make progress.

  • Investigating
    UTC
    Investigating

    We're aware that some users are unable to connect or reconnect the Zapier integration, seeing an OAuth or authorization error. Our team is investigating and will post updates here as we learn more. This is impacting all customers using Zapier and Dovetail.

    If you're affected, no action is needed on your end right now — we'll update this page once we have a fix or workaround. We apologize for any inconvenience.