Dovetail - Free plan users unable to upgrade to a paid plan – Incident details

Free plan users unable to upgrade to a paid plan

Resolved
Partial outage 30 %
Started 24 days agoLasted about 2 hours

Affected

Dovetail web application

Partial outage from 3:00 PM to 4:38 PM

Billing & payments

Partial outage from 3:00 PM to 4:38 PM

Updates
  • Resolved
    Resolved

    The issue that prevented Free plan users from upgrading to a paid plan has now been resolved. All upgrade flows are working as expected. Users may need to refresh their screen for the fix to take effect.

    Thank you for your patience while we worked on this.

  • Identified
    Identified
    We’ve identified the issue blocking Free plan users from upgrading to a paid plan. A fix is being rolled out, and we’ll share an update once it’s fully deployed.
  • Investigating
    Investigating
    We’ve identified an issue where users on our Free plan are currently unable to upgrade directly in-product. Our team is actively investigating the cause. Workaround: If you’d like to upgrade in the meantime, please reach out to our Support team, who can assist you with subscribing. We’ll provide updates here as soon as more information is available.