Dovetail - Dovetail unavailable for all customers. – Incident details

Dovetail unavailable for all customers.

Resolved
Operational
Started 21 days agoLasted 19 minutes

Affected

Dovetail web application

Major outage from 7:01 AM to 7:20 AM

Projects

Major outage from 7:01 AM to 7:20 AM

Channels

Major outage from 7:01 AM to 7:20 AM

Ask Dovetail

Major outage from 7:01 AM to 7:20 AM

Magic features

Major outage from 7:01 AM to 7:20 AM

Billing & payments

Major outage from 7:01 AM to 7:20 AM

Updates
  • Resolved
    Resolved

    The issue has been identified and successfully resolved. Thank you for your patience.

  • Investigating
    Investigating

    Dovetail is currently unavailable for all customers. Our team is actively investigating the issue and we’ll keep you updated with regular progress reports. We appreciate your patience.