Dovetail - Unable to sign up to Dovetail – Incident details
All systems operational
Unable to sign up to Dovetail
Resolved
Degraded performance
Started about 2 years agoLasted about 2 hours
Updates
Resolved
Resolved
This incident has been resolved.
Monitoring
Monitoring
A fix has been implemented and we are monitoring the results.
Investigating
Investigating
We are investigating an issue where users cannot create new workspaces. Some users are able to sign up successfully, so please retry if you encounter any errors.